Home | Blog | FAQ

Using Stage Caller with a Windows computer


#1

I’m afraid I made a huge mistake. I purchased Stage Caller because it seemed like it would solve a quiockly approaching tech concern. But now, I have loaded the app, connected to Dropbox, but I can’t find a way to use my Windows based computer to cue my device.

Any help or instructions would be great!


#2

hmm - I don’t know of any midi/osc tools for windows - lemme google that a bit


#3

so, MIDI is tricky with windows because you’d need to have something that was compatible with applemidi (rtp midi + bonjour) - I don’t know of any off the shelf product that’ll do that… I’m sure there’s one out there, but I have no idea what it is

there are some OSC tools for windows but I’m not really well versed in them… you could find some OSC mobile apps that can be ‘programmed’ to send OSC events to remote devices… I’ve seen a few in the past, but I’d rather do the next option personally

you can setup a ruby or python environment on your windows box and run whatever’s necessary to get osc working… it’ll involve writing some code and installing a bunch of libraries - I haven’t needed to do this in a few years so I don’t think you want to go down this road - most recently I did setup a midi environment with nodejs… I can go into more detail with this as necessary - but I don’t do windows, so it’ll take me a few days to spin up an environment.

you could also setup a complete virtual environment of some linux flavor or osx using virtualbox on windows and then either go the ruby/python route (which is easier under linux as far as I’m concerned) or run qlab on osx

or you could rent a mac from somewhere, setup midi and trigger events with midikeys or some other midi app - or even run qlab and do midi & osc


#4

I know this thread is a few months old but thought it worth adding my two penneth as a new member. I have recently (today) been experimenting with the Android version of Stagecaller and triggering from a Windows 7 PC.

YES, IT WORKS, couple of small problems that I hope will be cured soon.

I am running Multiplay show control software, which outputs Midi control commands, so a good starting point from a control point of view.

I have also had to install two other software packages in order to make the connection to the phone. I have to say that it was a lot easier to set up than I imagined, couldn’t actually believe I had achieved it till the phone rang.

Firstly, you need to load LoopBe1, which is a free download and sets up an internal Midi port on the PC. It was very easy to set this up to communicate with Multiplay. There is no setup procedure needed for LoopBe1, it sets itself up.

Secondly, you need to download rptMIDI from Tobias Erichsen’s site, again, this is a free program. There is a tutorial page which explains how to download, install and setup the program. Again, that was very easy to do. Within the rptMIDI setup screen it is very easy to call up the LoopBe1 midi port using the tutorial as the guide.

When Stagecaller is loaded onto the phone and appropriately activated, the phone name appears in the participants box of rptMIDI. Just enable it and you should be connected.

I have a couple of problems at the moment, which I hope will be sorted soon, as I have a show to do in 4 weeks, only local AmDram stuff.

The swipe to stop does not appear to work at the moment, but that is documented in the Play store for this App. The other problem is a bit more serious and is that the ringer is triggered and stopped OK by the Midi commands on the first pass, but cannot then be triggered again until the action setup is altered and re-saved. Same again on the next pass. Did notice that the connection seemed to get lost after I sent the Note Off command to the phone to turn the ringer off. This may well be something I have done and not understood, or it may be a feature of this early version App, I have no idea which it is at the moment.

Think it is also worth mentioning that the delay between sending commands and the phone actually doing them was extremely fast, ideal really as I have to synch the phone ring with particular words in the script.

Anyway, thought I’d share this with you.


#5

ah cool! I’ve worked hard on getting latency down on android, but it’s hit or miss on some devices and/or networks

yeah - swipe to stop is DOA right now - I believe I need to write my own lock screen in order to get the functionality I imagine people want - I don’t have any idea when I’ll get that to work at the moment - I figure I need a few uninterrupted days in a row - this is difficult due to a 2.5 year old, but we’ll see

I know Tobias’ work well - I was going to contact him to license his library but decided to try to write my own first… and a year later it seems to have worked out (re: I totally should have licensed his library, android is just a pain) - I’ve didn’t know about LoopBe1, I will endeavor to work on my windows-midi setup for testing as I have no windows-midi setup at the moment

I’ll take a look at the stop trigger issues immediately - I’m about a week or two away from midi reconnect working as I think it should (it doesn’t always work now) - you can try using a midi heartbeat to see if that keep the connection alive past an off trigger, but you shouldn’t need to - regardless, I haven’t seen your exact problem, but its also not part of my testing rig yet - I’ll get back to you

and thank you…


#6

Thank you for StageCaller. Just what the doctor ordered.

Just a couple of extra notes on my setup, I described the PC setup and environment, but omitted to say what phone I was using for the testing as this may have a bearing on results. The phone was an HTC One M7 (old phone I know) and is running Android version 5.0.2. I am going to upgrade soon to a more modern one, but this is all I have at the moment. I was running the test using my normal home network with a BT Home Hub 3. I am based in the UK, but don’t hold that against me.

Thanks


#7

ah thanks - I test on a nexus 5x with 7.1.x and a samsung s3 mini (gt-I8190) running 5.x - in theory StageCaller can go down to 4.2.2 - but I no longer have a android jellybean device to test on

the nexus 5x is actually quite wonderful - the s3 mini is crap, but it works, and got much better when I rooted and installed cyanogenmod on it

I’m retesting alpha19 on the s3 tonight and tomorrow - I’ll get back to you


#8

ah - so yes - I completely hosed the audio player… I don’t know why I did, but I definitely did it - seriously, I went back through version control and I can see when I broke it

anyway, in addition to me breaking audio it turns out that the more recent versions of the android library set now correctly handle error states that I was running up against - which is probably why I didn’t notice…

I’ll have a new version with start/stop (as well as repeat, which is also broken) by end of day tomorrow (3/18/2017)


#9

Ok, got new version, mods work a treat, can now re-trigger successfully. Thanks.

Will be demonstrating to rest of cast tonight, so it should get a bit of a soak test.

Just a further bit of info for you. Been checking the latency values and seem to be getting nominally 100mS’ ish. Highest value that I noted was around 500mS. Either way, I can work successfully on stage with those values. Will continue to monitor latency, although I rather suspect that the 500mS was probably caused by PC. I am now using a dedicated WiFi router for testing, so nothing else should be coming down the Ethernet line, however, the PC seems to be doing lot’s of other little things at the moment.

Thanks for all your efforts.


#10

I see similar latency numbers on my test MIDI setup - I’d love to get that into the 50-150ms average range but I’m not sure how to get there yet - to be honest, I haven’t checked the OSC latency recently…

latency is also related to the device and android version - my nexus5x with 7.x looks to be around 150-300ms while my samsung s3mini with 5.x is 300-500ms - so chances are your network is fine regardless… (unless you’ve got some really noisy dimmer packs around the stage or you stream 4k video over wifi)

I’ve had some luck with a (free) product called iStumbler (for mac) - it’ll give you an idea of how densely populated the wifi channels are around you and it’s moderately useful for determining if you’ve got something that’s blowing out a wifi channel periodically (I had an old microwave that would do that)

there is one unfortunate thing that I can’t seem to fix - I’m seeing an 8 to 10 second delay from when you first connect over MIDI to when the device is able to receive MIDI commands (at least with my mac setup - I haven’t setup my windows testbed yet) - I originally thought it was due to Apple MIDI session synchronization, but now I don’t think so (incidentally, the delay is about 3 seconds with a mac<->ios stagecaller MIDI) - it’s probably Apple screwing with me