Home | Blog | FAQ

Trouble Getting StageCaller to Work Reliably


#1

I’m trying to fire (3) I-Devices using OSC commands from QLab 3. When it works, it’s wonderful! Unfortunately it seems like after an indeterminate period of time the devices “disconnect” and will no longer respond to the OSC command until the device is reset. The wireless network is robust, there’s nothing on the network except the 3 devices and the QLab machine. This wifi signal is by far the strongest with only a couple of other weak signals present in the space. ()Not mine - I can’t control them). However the devices have all been set to “forget” all WLANS except mine.

Under STATUS, MIDI, OSC Heartbeat and Background are all turned on. Arm/Disarm is off.

Under Settings, Run In Backgroundand Require Heartbeat are turned on. Heartbeat action is: OSC:/heartbeat
Require Arm/Disarm is off.

I’m using Custom Cues from QLab: /cue/1/start

Distance between the devices and the wireless router doesn’t seem to make a difference. In any event this is a small theater with no obstructions and the devices are always within say 30’ of the router.

It may be semi-time dependent. if you fire it every couple of minutes it seems to continue to work. Let it sit for an undetermined period of time and it stops, almost like it’s lost the connection.

We are in tech this week for a show that opens on Friday. Any htoughts?


#2

hmm - well, you’ve got background & heartbeat on which should be keeping the radio alive - do you have anything receiving the heartbeat to see when it cuts out?

it’s a long shot, but we’ve seen issues with certain wireless access points that’ll “sleep” a connection as a power saving feature (netgear used to do this, it’s silly) - try and see if the wireless access points have the latest firmware - if you’re running apple airports you shouldn’t have a problem

can you give me the model & ios version on each device?


#3

No, not sure how to monitor the heartbeat. I do have TouchOSC and think I can use that, but I’m not sure.

So to confirm, under Edit Heartbeat / MIDI & OSC Basics, I set the output protocol to TCP and set the OSC Target Address to the IP address of my QLab computer. Alll Message Format Options are off. I this correct? Anything else I should look for in setting this up?

The theory about the router “sleeping” the connections may be valid. I got everything orking before last night’s rehearsal. None of the devices was used in Act I. When I checked them at intermission (about an hour and a half after initial testing) all of them were “lost”. I power cycled the devices and restarted StageCaller and they all came back pretty quickly. The to phones were used within 45 minutes after that and irked fine. The IPad wasn’t used until approaching an hour after the reboot and it failed!

The devices are as follows:
Router: SMC Barricade #SMCCWGBR14-N. This is an old router but still working. I can’t find any sleep settings on it. Can you recommend an inexpensive alternative that will work? I don’t have budget for a really good one.

Phones are iPhone 5 running either IOS 8 or 9.
IPad is probably a couple of years old and running IOS 8.


#4

its interesting that it’s cutting out after 45-60 minutes - that’s usually not iOS doing that (in theory it would try to save power a lot earlier than that… say within 10 minutes or so) - and on top of that you’re running ios8/9 which is a bit more lenient on long running background processes (like stagecaller)

if you had another access point sitting around around I’d say try it out - but don’t go buying something on the off chance that it’ll fix everything

I’ve tested on netgear, linksys, airport express & airport extreme - all recent models work well - I had a lot of problems with netgear a few years ago, but they seem to have fixed something since then - if you’re in the NYC vicinity I can stop by with a spare router

also : you should use UDP for the OSC heartbeat output protocol - to be honest I’m not sure why I added TCP as an option - the message format stuff shouldn’t affect sending heartbeat, its just some more data in the OSC path string

I usually use OSC Data Monitor by Kasper Kamperman (https://www.kasperkamperman.com/blog/osc-datamonitor/ ) although it’s a bit confusing to use, or even download


#5

while trying to duplicate this issue I found a bug in the heartbeat OSC target address field - it keeps changing to 127.0.0.1

that could be a problem… I’m gonna take a quick look at this and get back to you


#6

so when you touch the OSC Target Address field and enter in something valid (say, 10.209.1.50) when you leave that field, either by touching OSC Target Port or even Save, the address field reverts to 127.0.0.1 - I don’t know how long this bug has been here (I can check, but I’m afraid to) but it’s bad, and it basically broke OSC Heartbeat completely

I’ve pushed a new release that fixes this to Apple - that’ll go live whenever Apple decides to review the app (usually within 36 hours, but not always)

in the mean time I would like you to try turning on MIDI and changing the heartbeat to a MIDI heartbeat - doesn’t matter what it sends, and it shouldn’t matter if it is received by anyone - but it should give you the benefit of keeping the radio live… I’m curious if it’ll impact your 45-60 minute limit from before


#7

I didn’t get your message about the broken OSC heartbeat and recommendation to implement MIDI heartbeat until too close to curtain last night, but thanks for your diligence in the discovery and repair efforts! For last night’s performance, we stopped and restarted StageCaller on each device at intermission and everything ran flawlessly in Act II. While the heartbeat issue could certainly be a problem, in thinking about this logically, three devices most likely wouldn’t randomly break at the same time. The commonality would seem to be the wireless router. I now suspect that perhaps it’s radio is randomly glitching, causing it to lose connection with the iDevices. I picked up a new Linksys router which I’ll install tonight. I’ll also turn on the MIDI heartbeats and try to get a monitor installed so I can watch them. Hopefully these efforts and your own will fix this!

Again, thank you for your quick response to this “crisis”.

BTW I would take you up on your offer to visit us, but we are outside of Chicago, a little too far for a quick drop in.

Bob


#8

There are many advantages to using QLab 4 with Stage Caller

I have added a chapter to Mic Pool’s QLab Cook Book on using StageCaller with QLab 4.1.
As well as being an attempt to concisely detail the set up procedure it also demonstrates some novel possibilities that have only been possible with the latest QLab releases.
The aim of these is to make the most reliable QLab workspace for triggering sounds in StageCaller, and providing 2 backup strategies within the workspace, if the phone fails to ring.

QLab constantly monitors a heartbeat OSC message from StageCaller and if it is not present enables backup audio cues throughout the workspace.

When any StageCaller cue is triggered in QLab, the next cue playhead sits on a backup audio cue for a few seconds, before automatically advancing past it, if it is not required.

Together with a bespoke OSC logging system and a few other bells and whistles, I hope this is the most comprehensive guide yet.

Mic


StageCaller issues
#9

That’s a great recipe; it made me wish I was in a QLab shop! :slight_smile: