Home | Blog | FAQ

The " . " for the IP address

Dear all,

a newbie idiotic question.

I’m trying to add the IP of my notebook on Stagecaller in the Heartbeat OSC Target Address. It’s impossible for me to put the " . ". Only the " , " is given. I’ve tried all the possible, usual, iPhone keyboard combinations but nothing happens.

I’ve an iPhone SE 2020 with iOS 14.3 installed.

Grazie!

crap - I’m guessing that you’re in a country where a comma is used to denote the radix point (decimal point?)

so, your edit heartbeat screen doesn’t look like this:

… hmm … I set those IP entry fields to use the system decimal pad keyboard - I’m embarrassed to say that I didn’t consider non US field entry when I designed this… or at least sanitized the field on save to switch commas to periods…

you can try changing your region settings (Settings > General > Language & Region) to something more US-englishy - mine looks like this:

I know it’s not an ideal solution, but I’m not planning on releasing another version of stagecaller…

I’m really sorry about this - it’s just sloppy on my part