Home | Blog | FAQ

Multiple Devices Dropping Out


#1

Ok so I have a pair of iPhone 4 devices running iOS7, a Linksys WRT54GL, a Mac Mini running OS10.9 and QLab 3. I’m firing phone rings via OSC messages in QLab.

We went through 3 days of tech with absolutely no issues. The phones rang every time. I had the router sitting next to me in the house, my macbook and the sound mac mini plugged in via ethernet, and the mac mini and iphones on a dedicated wireless sound network.

When we started previews I moved the router up to the booth, and that’s when the problems started. I tried keeping the mini plugged into the router, and unplugged and connected wirelessly. Then I realized that the problem was the phones disconnecting from the network.

I tried all sorts of things with the phones. I turned off all notifications except StageCaller, turned off cellular and bluetooth services, made them forget all networks except the sound ones, turned off "ask to join networks. Today I started using the heartbeat feature, and that works great. As long as I can see midi messages, the ques fire instantly. Once the phones go into standby mode though (screen lock), they disappear after a few minutes. Sometimes one, sometimes the other, sometimes both. I turned off auto-lock and I’ve had them sitting here next to me, on, for a couple hours now and they haven’t dropped out at all.

Any thoughts? iPhone settings or router settings I should try?


#2

After I posted this, I moved the router out of the booth and onto the grid. It’s been four hours and both phones have stayed connected consistently.


#3

So the phones started disconnecting from the network again. Luckily because of the heartbeat the op can tell and be prepared with the backup. We lost one of the phones by intermission. We checked, and it had changed IP addresses. We got it reconnected and changed the IP address in QLab, and then we lost the other one. Five minutes into act 2 we lost the first one again. Any thoughts? The only other thing I can think of is to turn off the auto lock feature and make sure the phones stay active for the whole show.


#4

sorry for the delay - can you try setting static ip addresses for the phones - dhcp shouldn’t be changing ip even with an unstable network… it could be that another device is coming online and clobbering the phone ip (possible, but that seems unlikely…)

the OSC library I’m using ‘should’ be reconnecting if the ip of the device stays the same (although I should run some tests to really make sure of that)

assuming that the grid where the router lives is line of sight to the devices, your signal should be fine - you could try switching wifi channel, but that’s just a shot in the dark