Home | Blog | FAQ

Iphone 4 IOS 7.1.2 SC v 1.3.9 Crashes when trying to add an action


#1

I just updated our stage phones from 1.3 to 1.3.9 to be able to connect to google drive.
I hadn’t updated previously as the last use in November 2017 still allowed connection to google drive, so it wasn’t an issue.
Now I have connection to google drive, but when tapping the + to add an action, SC crashes.
Any thoughts on this? any way to go back a version?


#2

sounds like some kind of preference got squashed during the update from 1.3 to 1.3.9 and that’s crashing the app - lemme see if I can duplicate on my end to make sure it’s not a larger issue (although that’ll be tough since I don’t have a working ios7/8 device anymore)

the first thing I’d try would be to delete/reinstall the app on one device and see if that fixes it - if it does, good… then it’s probably a bad preference and its just my lazy coding that caused the problem - if it doesn’t we have a more systemic issue that I’m not sure how to address at this time

apple is supposed to allow you to download the last available version for any given ios version, meaning you should be able to delete and reinstall easily, but just in case it would be advisable to have the device backed up to a mac

now, I’m not sure that ios7 is compatible with the most recent version of itunes - so you’ll have to use an older version of mac os - it may be more trouble than its worth…

if you have an old mac running an old version of itunes and you already had a backup of one of the devices, you should be able to restore an older version of stagecaller that might work… (granted, stagecaller on ios7 prior to v 1.3.9 will have a broken google drive and you’ll be forced to load sounds through the media library on the device)


#3

already tried deleting and re-downloading the app and get the same results, also on multiple phones of same ios. I did a back up of the show phone on version 1.3 and used that to restore to the phone I had ipdated, but SC remained at 1.3.9 . I removing SC from the updated phone and tried to restore from backup again, but it did not restore SC and had to dl from app store again. all with same results, although the actions loaded, but SC crashes again when trying to edit or add an action. Is there a way to make 1.3.8 the last working version for IOS 7 from your end if you can’t readily find the error?
So far I haven’t been able to install an older version of SC, still trying!


#4

I can’t change the last working version with apple - they no longer support ios7 or the iphone4 - so they won’t help me on this - I could try to do a custom ad hoc build, but apple has modified their app signing over the years and may not let me do that for unsupported devices, besides the fact that I can’t duplicate the problem - my 3gs (ios 6.1.6) and my 4s (ios 9.3.5) run without issue - the earliest simulator I can run at this time is a 4s with 8.4, and that also runs without issue

all the devices are iphone4 - right?

how about this:
in stagecaller > settings, select ‘delete all sounds and actions’ - then, try to create an action (without downloading any sounds first - just like a vibrate action)

if it still crashes I have another plan - we could try creating a fake stagecaller backup manually with the actions & sounds defined and load it in via google drive…


#5

so I spent today spinning up a VM of osx 10.10.5 in the hope of running xcode7 with a ios7.1.x simulator - I got everything working except the simulator, apple really hates developers

regardless - there is something I can do about 1.3.9 - I can’t validate that 1.3.9 works or doesn’t (it works on my 4s, with ios 9.x, but that doesn’t compare to a iphone 4 with ios7), but I can validate that 1.3.8 works on ios 6 (on a 3gs) - it does (at least it did, I’m recharging my 3gs to verify)

if 1.3.8 works (ie: doesn’t crash on action create) then that’ll give you the ability to load sounds from the device media library (v1.3.8 drops dropbox & google drive because they’re no longer compatible with ios6)

and the way I give you 1.3.8 is I tell apple that the last acceptable version of stagecaller for ios7/ios8 is 1.3.8 - which I can totally do (and completely forgot that I could)

I feel its a shitty way to drop support for the iphone4, but if its the only way it’ll work I’m not sure what else I can do

I’ll power up my 3gs and test what I can in the morning - if it seems functional I’ll remove 1.3.9 from the store which should leave you with only 1.3.8

I’ll also look into where iTunes stores iphone apps - I think we can backup your functional v1.3 app manually and restore it if necessary


#6

Let me know when/if 1.3.8 is ready to go and I will test that on one of my 4.

We did end up getting a pair of 5s with ios 11.2.6 and SC 1.3.12 and are finding that when wifi drops (or is turned off) and returns heartbeat is not restarting until the app is closed and reopened or going into SC settings and turning off then restarting heartbeat (tcp) or going into the settings page (UDP) will restart heartbeat on it’s own.
Sorry to be a problem child!


#7

ok - 1.3.9 has been removed - you should be able to pickup 1.3.8 (I hope)

on the hearbeat restart : that’s a good bug, thanks - I thought I had patched that - I’ll have that fixed in the next release


#8

Thanks Jay, 1.3.8 download confirmed.